hyperlinks don't seem to do anything

I'm sure these used to work and they are displayed underlined and change icon to a hand, but i click on them and nothing happens. I'm using firefox as my default browser (dunno if that makes a difference?). It's hardly a killer issue, as I can easily copy and paste the link.
Your rating: None
Average: 1 (1 vote)


This is on Mac right? It seems to work over here.. I'm using Firefox as well.

Polonium 210's picture

I'm on Mac OsX 10.6.8 and I use Firefox latest release. I can testify that hyperlinks don't work.

Hmm, I can't get this to happen in either my virtual machine or Hackintosh setup... I'm at a loss as to what might be causing this difference. Is this in room chat or private chat?

mine's on windows 7... sorry forgot to mention.

Normally these are problems with links sent through private chat (not sure about rooms)

I do use noscript with firefox (main reason i with firefox to be honest) - could this be affecting things?

I wish I had a clue. The text control that displays chat is supposed to have built in functionality for opening links, which is working over here. But I can handle the link click event and manually try to open the link in an external browser. Maybe that'll work better for you. I'll post a modified version of the client later today.

Thanks, Nir

Here, SoulseekQt-2-20-2012.exe (Windows only for now) manually captures link click events as suggested above. Might not make much of a difference as Qt is supposed to do the same thing on its own anyway, but it's the only thing I can think of right now. Let me know how it works out.

Thanks, Nir

Not sure whether this is good news or bad news, but this new version seems to fix the issue. Hyperlinks now open in a new tab in firefox.

Thanks for the updated version ;)

Excellent! Then I can I just roll this change into the next version. Thanks!